RT-680 Auger motor making loud screeching noises

Hawaiianbrian

New member
Messages
3
Grill(s) owned
  1. RT-680
hey all- I have rt-680. on occasion the auger seems to clog, not an issue, I unclog it, shop vacc the pot put all back together- with a handful of pellets in hopper
- sometimes it works fine- using fresh pellets- like this morning- then it seems to stop and loud screeching noise for 10-30 seconds then works as normal operation-
ideas?
 

C. Keeper

Transitioned
Lifetime Premium!
Premium Member
Messages
5,489
Grill(s) owned
  1. Bull
  2. Bullseye
  3. RT-680
hey all- I have rt-680. on occasion the auger seems to clog, not an issue, I unclog it, shop vacc the pot put all back together- with a handful of pellets in hopper
- sometimes it works fine- using fresh pellets- like this morning- then it seems to stop and loud screeching noise for 10-30 seconds then works as normal operation-
ideas?
Sounds like gears in auger motor, replace it and see what happens.
 

chadinsc

Well-known member
Messages
1,081
Location
upstate south carolina
Grill(s) owned
  1. Bull
depending on how you use your grill. a 3rpm bfg auger motor could be of benefit to you. if all you do is low and slow then its not really any better. there is a long thread about it under the 700 section
 

ol' stonebreaker

Well-known member
Military Veteran
Messages
335
Grill(s) owned
  1. RT-300
Vac all the pellets out and run the auger tube empty by running the auger by itself to see if the noise goes away. Makes me wonder if there's a piece of metal hung up on an auger flight.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top