Auger motor dead after 3 months

bpgt64

New member
Messages
3
Grill(s) owned
  1. RT-1250
I think my auger motor is dead after like 9 cooks in the last summer. I took delivery in July and I can’t seem to get it to crank up at all. Pot heats up fine, and will burn, but the motor is not turning at all ever after cleaning the whole thing out. I filed a support request with recteq, just wondering how long I am likely dead in the water?
 

Jim6820

The Crazy Ol’ Basque!
Premium Member
Military Veteran
Messages
1,069
Location
Northwest corner of Washington state.
Grill(s) owned
  1. Trailblazer
Recteq usually responds pretty quickly. If you haven’t called them on the phone and spoken directly to a customer service staffer, I would encourage you to do so. “Filing a support request” online doesn’t always get the same priority as does a direct conversation.
 

Jim6820

The Crazy Ol’ Basque!
Premium Member
Military Veteran
Messages
1,069
Location
Northwest corner of Washington state.
Grill(s) owned
  1. Trailblazer
Auger was jammed, had to take a hammer/flat head and a shop vac to it to get the auger out after removing the motor. Recteq support was fantastic through out the the whole process.
Glad you got the problem worked out. Nice to hear that "Recteq support was fantastic."
 

gtg450g

New member
Messages
2
What did you end up doing? How do you remove the auger? I removed the pellets and the six screws in the hopper but still cannot pull it up and out to get to the auger.

I have the grill built-in with a folded over full length cover over it. We’ve had a lot of rain lately, and — even though the pellets in the hopper are fine — the auger is completely jammed!
 

okie

Premium Member!
Premium Member
Military Veteran
Messages
403
Grill(s) owned
  1. RT-1070
How did it get jammed? Do you keep it covered or under a roof when not in use?
 

bpgt64

New member
Messages
3
Grill(s) owned
  1. RT-1250
How did it get jammed? Do you keep it covered or under a roof when not in use?
I wasn't emptying the pelet hopper after cooks, and burning down the feed line. I now do that...and no problems.
 

C. Keeper

Dressed to Kill
Lifetime Premium!
Premium Member
Messages
5,899
Grill(s) owned
  1. Bull
  2. Bullseye
  3. RT-680
I think my auger motor is dead after like 9 cooks in the last summer. I took delivery in July and I can’t seem to get it to crank up at all. Pot heats up fine, and will burn, but the motor is not turning at all ever after cleaning the whole thing out. I filed a support request with recteq, just wondering how long I am likely dead in the water?
Sorry for your loss
 

SmokeOCD

Well-known member
Messages
740
I wasn't emptying the pelet hopper after cooks, and burning down the feed line. I now do that...and no problems.
That seems excessive. Yes it works, but it's a lot of extra work. I know I went into pellet-land because of ease.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top